Home » railML newsgroups » railml.common » [railml3.1] Change "v" to "speed" in attribute names (Applies to both infrastructure and interlocking domains)
[railml3.1] Change "v" to "speed" in attribute names [message #2062] Sat, 29 December 2018 00:57 Go to next message
Thomas Nygreen JBD is currently offline  Thomas Nygreen JBD
Messages: 68
Registered: February 2017
Member
Dear all,

It was suggested already in 2010 to rename speedChange/@vMax to @maxSpeed, but it was kept for backwards compatibility between 2.x versions. I see no reason not to improve the name in 3.1.

This applies to (with suggested changes):

  1. IS: Speed/@vMax -> @maxSpeed
  2. IS: SpeedSection/@vMax -> @maxSpeed
  3. IL: AspectRelation/@Vpassing -> @passingSpeed
  4. IL: AspectRelation/@Vexpecting-> @expectingSpeed


Mostly, other tSpeedKmPerHour attributes already have names that end with Speed. Exceptions that begin with speed are:

  1. IS: SwitchCrossingBranch/@speedBranching -> @branchingSpeed
  2. IS: SwitchCrossingBranch/@speedJoining -> @joiningSpeed
  3. IS: PantographSpacing/@speed4PantographSpacing -> @pantographSpacingSpeed
  4. IL: LevelCrossingIL/@speedRestriction-> @unprotectedSpeed
  5. IL: Overlap/@speedInOverlap-> @speed or @maxSpeed (do not repeat element name)


Best regards,
Thomas Nygreen
Railway capacity engineer
Jernbanedirektoratet

[Updated on: Sat, 29 December 2018 01:01]

Report message to a moderator

Re: [railml3.1] Change "v" to "speed" in attribute names [message #2067 is a reply to message #2062] Sun, 30 December 2018 05:32 Go to previous messageGo to next message
Joerg von Lingen is currently offline  Joerg von Lingen
Messages: 148
Registered: May 2011
Senior Member
Thanks for your specific comments. I will consider this during current
refactoring of schema.

Best regards,
Joerg v. Lingen

Rollingstock Coordinator

On 29.12.2018 00:57, Thomas Nygreen wrote:
> Dear all,
>
> It was suggested already in 2010 to rename speedChange/@vMax
> to @maxSpeed, but it was kept for backwards compatibility
> between 2.x versions. I see no reason not to improve the
> name in 3.1.
>
> This applies to (with suggested changes):
> IS: Speed/@vMax -> @maxSpeed IS: SpeedSection/@vMax ->
> @maxSpeed IL: AspectRelation/@Vpassing -> @passingSpeed IL:
> AspectRelation/@Vexpecting-> @expectingSpeed
>
> Mostly, other tSpeedKmPerHour attributes already have names
> that end with Speed. Exceptions that begin with speed are:
> IS: SwitchCrossingBranch/@speedBranching -> @branchingSpeed
> IS: SwitchCrossingBranch/@speedJoining -> @joiningSpeed IS:
> PantographSpacing/@speed4PantographSpacing ->
> @pantographSpacingSpeed IL:
> LevelCrossingIL/@speedRestriction-> @unprotectedSpeed IL:
> Overlap/@speedInOverlap-> @overlapSpeed
Re: [railml3.1] Change "v" to "speed" in attribute names [message #2092 is a reply to message #2062] Sun, 13 January 2019 16:31 Go to previous messageGo to next message
Vasco Paul Kolmorgen
Messages: 55
Registered: November 2004
Member
Dear Thomas,

thank you very much for the attention and support of railML development.

Am 29.12.2018 um 00:57 schrieb Thomas Nygreen:
> It was suggested already in 2010 to rename speedChange/@vMax
> to @maxSpeed, but it was kept for backwards compatibility
> between 2.x versions. I see no reason not to improve the
> name in 3.1.

I filed a ticket #353 (see https://trac.railml.org/ticket/353) to handle
this problem. During development of Release Candidate 2 of railML 3.1 we
will rename the elements.

Please let us know if you suspect further problems with unclear terms.

Best regards,
--
Vasco Paul Kolmorgen - Governance Coordinator
railML.org (Registry of Associations: VR 5750)
Phone railML.org: +49 351 47582911
Altplauen 19h; 01187 Dresden; Germany www.railML.org
Re: [railml3.1] Change "v" to "speed" in attribute names [message #2105 is a reply to message #2062] Fri, 18 January 2019 11:27 Go to previous message
christian.rahmig is currently offline  christian.rahmig
Messages: 439
Registered: January 2016
Senior Member
Dear Thomas,
dear all,

Am 29.12.2018 um 00:57 schrieb Thomas Nygreen:
> [...]
> This applies to (with suggested changes):
> IS: Speed/@vMax -> @maxSpeed IS: SpeedSection/@vMax ->
> @maxSpeed IL: AspectRelation/@Vpassing -> @passingSpeed IL:
> AspectRelation/@Vexpecting-> @expectingSpeed
>
> Mostly, other tSpeedKmPerHour attributes already have names
> that end with Speed. Exceptions that begin with speed are:
> IS: SwitchCrossingBranch/@speedBranching -> @branchingSpeed
> IS: SwitchCrossingBranch/@speedJoining -> @joiningSpeed IS:
> PantographSpacing/@speed4PantographSpacing ->
> @pantographSpacingSpeed IL:
> LevelCrossingIL/@speedRestriction-> @unprotectedSpeed IL:
> Overlap/@speedInOverlap-> @overlapSpeed

I did the following renamings:
* <speedSection>
- @vMax --> @maxSpeed
* <switch><*branch>
- @speedBranching --> @branchingSpeed
- @speedJoining --> @joiningSpeed

Best regards
Christian

--
Christian Rahmig - Infrastructure scheme coordinator
railML.org (Registry of Associations: VR 5750)
Phone Coordinator: +49 173 2714509; railML.org: +49 351 47582911
Altplauen 19h; 01187 Dresden; Germany www.railml.org


Christian Rahmig – Infrastructure scheme coordinator
railML.org (Registry of Associations: VR 5750)
Altplauen 19h; 01187 Dresden; Germany www.railML.org
Previous Topic: [railml3.1] cleanup of unused types
Next Topic: railML 3.x: Data Modelling Patterns
Goto Forum:
  


Current Time: Fri Jun 14 13:41:19 CEST 2024