Home » railML newsgroups » railml.interlocking » Abbreviations in element names - update
Abbreviations in element names - update [message #2386] Tue, 10 March 2020 05:12
Jörg von Lingen is currently offline  Jörg von Lingen
Messages: 87
Registered: March 2016
Dear all,

our common coordinator correctly found that interlocking part in railML3.1 does
not completely follow the modelling patterns w.r.t. to use of abbreviations in
element names. In the end of the discussion it was decided that railML3.2 will
not be 100% downwards compatible to railML3.1, i.e. some renaming shall take place.
Here are the attributes and elements subject to renaming

- bitNr -> bitNumber
- SWversion -> softwareVersion
- lastSupervisedSectionBeforeDP -> lastSupervisedSectionBeforeDangerPoint

- assetsForIL -> assetsForInterlocking
- specificIMs -> specificInfrastructureManagers
- specificIM -> specificInfrastructureManager

On the other side "TVD" was considered to remain as it seems a quite common
abbreviation and full text "TrackVacancyDetection" would unnecessarily bloat the

As especially the elements might you affect please state your opinion on the
issue here.

This post from Dec 23 last year seems to be vanished from my newsreader but is still in webreader. As I did not receive
any response from community I have asked directly. Thus I got indication from Fabiana (NEAT) and Heidrun (Thales) the
renaming for next version wouldn't be a problem to them. So I will do it.

Jörg von Lingen - Interlocking Coordinator
Previous Topic: Abbreviations in element names
Next Topic: [railML3]: RouteRelation
Goto Forum:

Current Time: Mon Jun 17 01:55:37 CEST 2024