Home » railML newsgroups » railml.interlocking » Time vs. Timer in element and attribute names (Currently used inconsistently)
Time vs. Timer in element and attribute names [message #2063] Sat, 29 December 2018 01:19 Go to next message
Thomas Nygreen JBD is currently offline  Thomas Nygreen JBD
Messages: 68
Registered: February 2017
Member
Dear all,

A timer is an object, not a time period or duration. Therefore, anything called *Timer should be a reference to a timer, or a description of one. The 3.1-RC has some attributes that end in Timer, all of type xs:duration, which should be renamed to *Time:
  • maxThrowTimer
  • constantWarningTimer
  • releaseDelayTimer
  • callOnAspectTimer
  • keyRequestTimer
  • keyAuthoriseTimer
  • endSectionTimer
  • residualRouteCancellationTimer
  • partialRouteReleaseTimer
  • invalidTolerationTimer
  • switchoverTolerationTimer

The following attributes are already named *Time:
  • typicalThrowTime
  • minimumOpenTime
  • maximumClosedTime
  • overlapValidityTime

There are also two elements named *Timer: overlapReleaseTimer and hasSignalDelayTimer. These can be interpreted as a description of an actual timer, and the names are therefore suitable. However, the attribute @timer of overlapReleaseTimer should be renamed to @time or @delay. The latter matches hasSignalDelayTimer/@delay.


Best regards,
Thomas Nygreen
Railway capacity engineer
Jernbanedirektoratet
Re: Time vs. Timer in element and attribute names [message #2065 is a reply to message #2063] Sun, 30 December 2018 05:21 Go to previous message
Joerg von Lingen is currently offline  Joerg von Lingen
Messages: 148
Registered: May 2011
Senior Member
Thanks for your specific comments. I will consider this during current
refactoring of schema.

Best regards,
Joerg v. Lingen

Rollingstock Coordinator

On 29.12.2018 01:19, Thomas Nygreen wrote:
> Dear all,
>
> A timer is an object, not a time period or duration.
> Therefore, anything called *Timer should be a reference to a
> timer, or a description of one. The 3.1-RC has some
> attributes that end in Timer, all of type xs:duration, which
> should be renamed to *Time:
> maxThrowTimer constantWarningTimer releaseDelayTimer
> callOnAspectTimer keyRequestTimer keyAuthoriseTimer
> endSectionTimer residualRouteCancellationTimer
> partialRouteReleaseTimer invalidTolerationTimer
> switchoverTolerationTimer
>
> The following attributes are already named *Time:
> typicalThrowTime minimumOpenTime maximumClosedTime
> overlapValidityTime
>
> There are also two elements named *Timer:
> overlapReleaseTimer and hasSignalDelayTimer. These can be
> interpreted as a description of an actual timer, and the
> names are therefore suitable. However, the attribute @timer
> of overlapReleaseTimer should be renamed to @time or @delay.
> The latter matches hasSignalDelayTimer/@delay.
Previous Topic: railMLv3: TVD Section demarcatingTrainDetection
Next Topic: Using type EntityILref for references to the infrastructure domain
Goto Forum:
  


Current Time: Mon Jul 15 09:43:51 CEST 2024