Home » railML newsgroups » railML.infrastructure » need for new attribute "virtual" of trainDetector
need for new attribute "virtual" of trainDetector [message #1255] Wed, 23 September 2015 22:50
Joachim Rubröder railML is currently offline  Joachim Rubröder railML
Messages: 0
Registered: November 2019
Presently, railML defines traindetection elements that has children
trainDetector and trackCircuitborder.

Now, the interlocking model introduces the Virtual Subsection (VSS). The
VSS has either physical limits such as track insulators or axle counters
or, as the name suggests, a virtual limit.

I plead for the introduction of a boolean attribute "virtual" to the
trainDetector element. Suggestion for documentation: "true if this element
delimits a Virtual Subsection, false if this is a physically exisiting
train detection device such as an axle counter or a pedal".

If a user defines <trainDetector ... virtual="yes"/>, we're dealing with a
virtual section limit.

I can't export the virtual limit to the IL namespace because I need all
VSS-limits to be fully defined in the IS namespace. This allows one to do
graph-like operations like finding all (virtual) sections along a route.

I would need this in railML 3.

----== posted via PHP Headliner ==----
Previous Topic: RailML-compliant?
Next Topic: Re: Missing 'any' attributes/elements
Goto Forum:

Current Time: Fri Jul 12 21:03:30 CEST 2024