Home » railML newsgroups » railml.infrastructure » Infrastructure registers
Infrastructure registers [message #1547] Mon, 10 April 2017 14:56 Go to next message
christian.rahmig is currently offline  christian.rahmig
Messages: 44
Registered: January 2016
Member
Dear all,

with railML version 2.2 we introduced the OCP sub-element <designator>
with its attributes @register and @entry (see [1]). At the 31st railML
Conference in Berne on 22.03.2017, the introduction of timetable related
register references has been discussed. In order not to mix registers
with different purposes, it is necessary to distinguish between
infrastructure and timetable registers. Therefore, it has been suggested
to rename @register into @infrastructureRegister in order to indicate
what kind of register shall be referenced (see [2] for more details).

[1] https://trac.railml.org/ticket/112
[2] https://trac.railml.org/ticket/310

Best regards
Christian

--
Christian Rahmig - Infrastructure scheme coordinator
railML.org (Registry of Associations: VR 5750)
Phone Coordinator: +49 173 2714509; railML.org: +49 351 47582911
Altplauen 19h; 01187 Dresden; Germany www.railml.org
Re: Infrastructure registers [message #1580 is a reply to message #1547] Thu, 18 May 2017 15:46 Go to previous message
Dirk Bräuer is currently offline  Dirk Bräuer
Messages: 202
Registered: August 2008
Senior Member
Dear Christian,

sorry but I don't understand the necessity. May be you can further explain?

From my understanding, the kind of register is (adequately) specified
by the parent element of <designator>. If it is a <designator> of an
<ocp>, the station registers are needed. If it is a <designator> of a
different parent element, a different register is needed.

As is can also happen to have different registers as sub-elements of
<infrastructure> in future (such as registers of line numbers), I would
not recommend naming the station lists @infrastructureRegister. I would
name them @ocpRegister. But this would, as I said, be redundant to the
parent's element name.

I agree that the file "Registers.xml" should not be named such in
future. It should be named "Registers_of_OCPs.xml" or such. But this
does not need to have consequences for the XSD, does it?

Best regards,
Dirk.
Previous Topic: Modeling of switches
Next Topic: Track: description vs. trackDescr
Goto Forum:
  


Current Time: Sat May 27 02:34:33 CEST 2017