Home » railML newsgroups » railml.infrastructure » [railML3|alpha] Empty <choice/> in RTM_ElementPartCollection
[railML3|alpha] Empty <choice/> in RTM_ElementPartCollection [message #1413] Fri, 02 September 2016 11:50 Go to next message
Felix Prüter is currently offline  Felix Prüter
Messages: 16
Registered: June 2016
Location: Berlin
Junior Member
Hi Christian,
our XML Validator complains about an unexpected <elementPart> element in <elementUnorderdCollection> of an netElement (in the both example XMLs). Some debugging shows that the reason is the empty <xsd:choice/> element in RTM_ElementPartCollection, which RTM_UnorderdCollection inherites from.
Was an empty <sequence/> intended instead?

Best regards
Felix

[Updated on: Mon, 10 October 2016 19:01] by Moderator

Report message to a moderator

[railML3|alpha] Re: Empty <choice/> in RTM_ElementPartCollection [message #1414 is a reply to message #1413] Mon, 05 September 2016 13:48 Go to previous message
christian.rahmig is currently offline  christian.rahmig
Messages: 44
Registered: January 2016
Member
Hi Felix,

Am 02.09.2016 um 11:50 schrieb Felix Prüter:
> [...] Some debugging shows
> that the reason is the empty <xsd:choice/> element in
> RTM_ElementPartCollection, which RTM_UnorderdCollection
> inherites from.
> Was an empty <sequence/> intended instead?

you are totally right! Thank you very much for having the enquiring eye!
As this was a mistake in the UML model of the railML3 alpha version, I
could easily correct it and you will find the result with the next alpha
version.

Best regards
Christian
--
Christian Rahmig
railML.infrastructure coordinator

[Updated on: Mon, 10 October 2016 19:01] by Moderator

Report message to a moderator

Previous Topic: InfraAttributes and InfraAttrGroups
Next Topic: [railML3|alpha] Linear coordinates
Goto Forum:
  


Current Time: Thu May 25 07:08:26 CEST 2017