Home » railML newsgroups » railml.rollingstock » Version 0.93 - request for comment
Version 0.93 - request for comment [message #1165] Tue, 06 April 2004 15:08 Go to next message
Joerg von Lingen is currently offline  Joerg von Lingen
Messages: 56
Registered: May 2011
Member
Hallo,

as briefly described during meeting in Brunswick the latest version of rollingstock scheme is 0.93
with the major addition of train related data in <formation> branch. However, it is still possible
to discuss the best "mounting point" of this branch:
1. railml --- rollingstock --- rs <= vehicle related
|
-- formations --- formation <= train related
*or*
2. railml --- rollingstock --- rs <= vehicle related
|
-- formation <= train related

Please give me your opinions.

Best,
Joerg von Lingen
Re: Version 0.93 - request for comment [message #1166 is a reply to message #1165] Wed, 07 April 2004 15:17 Go to previous messageGo to next message
Matthias Hengartner is currently offline  Matthias Hengartner
Messages: 57
Registered: August 2003
Member
Hello,

I'd prefer not to have <formations> as another direct child-element of the
<railml> root element. So I'm in favour of the second option.

But what about separating vehicle and train related data by means of two new
container elements? I mean something like this:

railml --- rollingstock --- vehicles --- rs <= vehicle related
|
-- formations --- formation <= train related

The naming of these container elements (<vehicles> and <formations>) would
have to be discussed probably (or shall we rename <rs> to <vehicle>?)

This version would be similar as we have it in the infrastructure (container
elements lines, tracks, operationControlPoints, etc.)


Other opinions?

Best regards,
Matthias Hengartner




"Joerg von Lingen" <jvl(at)bahntechnikde> wrote in message
news:GlwwHj9GEHA.1168@sifa...
> Hallo,
>
> as briefly described during meeting in Brunswick the latest version of
rollingstock scheme is 0.93
> with the major addition of train related data in <formation> branch.
However, it is still possible
> to discuss the best "mounting point" of this branch:
> 1. railml --- rollingstock --- rs <= vehicle related
> |
> -- formations --- formation <= train related
> *or*
> 2. railml --- rollingstock --- rs <= vehicle related
> |
> -- formation <= train related
>
> Please give me your opinions.
>
> Best,
> Joerg von Lingen
Re: Version 0.93 - request for comment [message #1167 is a reply to message #1166] Thu, 08 April 2004 08:37 Go to previous message
Joachim.Rubröder is currently offline  Joachim.Rubröder
Messages: 28
Registered: September 2004
Junior Member
Hello,
I agree that the schema should branch below the rollingstock element,
like in the infrastructure. And to rename the somehow cryptic <rs> to
<vehicle> would also be more railML like. So I will also vote for:

railml --- rollingstock --- vehicles --- vehicle <= vehicle related
|
-- formations --- formation <= train related

besr regards,
Joachim Rubröder


Matthias Hengartner schrieb:
> Hello,
>
> I'd prefer not to have <formations> as another direct child-element of the
> <railml> root element. So I'm in favour of the second option.
>
> But what about separating vehicle and train related data by means of two new
> container elements? I mean something like this:
>
> railml --- rollingstock --- vehicles --- rs <= vehicle related
> |
> -- formations --- formation <= train related
>
> The naming of these container elements (<vehicles> and <formations>) would
> have to be discussed probably (or shall we rename <rs> to <vehicle>?)
>
> This version would be similar as we have it in the infrastructure (container
> elements lines, tracks, operationControlPoints, etc.)
>
>
> Other opinions?
>
> Best regards,
> Matthias Hengartner
>
>
>
>
> "Joerg von Lingen" <jvl(at)bahntechnikde> wrote in message
> news:GlwwHj9GEHA.1168@sifa...
>
>> Hallo,
>>
>> as briefly described during meeting in Brunswick the latest version of
>
> rollingstock scheme is 0.93
>
>> with the major addition of train related data in <formation> branch.
>
> However, it is still possible
>
>> to discuss the best "mounting point" of this branch:
>> 1. railml --- rollingstock --- rs <= vehicle related
>> |
>> -- formations --- formation <= train related
>> *or*
>> 2. railml --- rollingstock --- rs <= vehicle related
>> |
>> -- formation <= train related
>>
>> Please give me your opinions.
>>
>> Best,
>> Joerg von Lingen
>
>
>
Previous Topic: formations of roolinfstocks
Next Topic: Version 0.94 - final request for comment
Goto Forum:
  


Current Time: Wed Mar 29 11:16:02 CEST 2017