Home » railML newsgroups » railml.infrastructure » meaning of 'up' and 'down' in mileageChange.dir and track.mainDir
meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #285] Mon, 26 March 2012 11:01 Go to next message
Dirk Bräuer is currently offline  Dirk Bräuer
Messages: 187
Registered: August 2008
Senior Member
Hallo allerseits,

Ich habe beim Erstellen von Beispielen zur Kilometrierung
(http://www.irfp.de/download/railml_doku_beispiele.pdf, Seiten 4 ff.)
quasi festgelegt, dass die Ausprägungen 'up' und 'down' der Attribute
mileageChange.dir und track.mainDir streng numerisch ("hochzählen",
"runterzählen") zu interpretieren sind und damit vom britischen
Sprachgebrauch abweichen, wo 'up' = "in Richtung London" und 'down' = "weg
von London" bedeuten.

Außerdem habe ich festgelegt, dass sich up/down von 'mainDir' immer auf
die _relative_ Kilometrierungsrichtung beziehen und damit abweichen vom
Attribut mileageChange.dir, wo sich 'dir' natürlich auf die absolute
Kilometrierungsrichtung bezieht. (Da es dort das Attribut 'absPos' gibt,
wäre es konsequenter, wenn es auch 'absDir' hieße.)

Der Grund für die Festlegung von track.mainDir auf relative
Kilometrierungsrichtung ist, dass sich track.mainDir immer auf das
_gesamte_ Gleis bezieht, während die absolute Kilometrierungsrichtung ja
eben innerhalb des Gleises mehrfach wechseln kann und damit nicht
eindeutig wäre.

Falls dies keine Zustimmung trifft, bitte ich um kurzfristigen Einspruch
zwecks Korrektur der Beispiele.

Danke!

---
In my examples on mileage I wrote that the values 'up' and 'down' of the
attributes 'mileageChange.dir' and 'track.mainDir' relate to numerical
interpretation (raising, falling = "to count up or down"). Therefore, they
differ from the typical usage in British English where 'up' relates on
"direction to London" and 'down' relates on "direction away from London"..

Additionally, I decided that up & down of 'mainDir' always refer to the
_relative_ mileage direction and therefore differ from the usage of the
attribute mileageChange.dir, where 'dir' of course refers to the
_absolute_ mileage direction.

The reason for this decision is that 'track.mainDir' always applies to the
whole track while the absolute mileage direction may change (several
times) along this track. Therefore, the absolute mileage direction is not
unique.


--
Erstellt mit Operas revolutionärem E-Mail-Modul: http://www.opera.com/mail/
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #295 is a reply to message #285] Thu, 05 April 2012 00:07 Go to previous messageGo to next message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Hello Dirk,

> Ich habe beim Erstellen von Beispielen zur Kilometrierung
> (http://www.irfp.de/download/railml_doku_beispiele.pdf, Seiten 4 ff.)
> quasi festgelegt, dass die Ausprägungen 'up' und 'down' der Attribute
> mileageChange.dir und track.mainDir streng numerisch ("hochzählen",
> "runterzählen") zu interpretieren sind und damit vom britischen
> Sprachgebrauch abweichen, wo 'up' = "in Richtung London" und 'down' =
> "weg von London" bedeuten.

Yes, your understanding of the direction attribute is correct. It always
relates directly to the direction of the increasing position value.

> Außerdem habe ich festgelegt, dass sich up/down von 'mainDir' immer auf
> die _relative_ Kilometrierungsrichtung beziehen und damit abweichen vom
> Attribut mileageChange.dir, wo sich 'dir' natürlich auf die absolute
> Kilometrierungsrichtung bezieht. (Da es dort das Attribut 'absPos' gibt,
> wäre es konsequenter, wenn es auch 'absDir' hieße.)

Consequently, also mileageChange elements need to be referenced to the
direction of the track, the so-called "relative direction" as you wrote
since they are elements on the track. Therefore the track's direction
parameter should be used as a reference. So, there doesn't exist an
"absolute direction" as it would be (like the absolute position) not unique.
Any comments from other users of the railML infrastructure schema? How
do you understand the direction parameter in the element <mileageChange>?

Best regards

---
Christian Rahmig
railML.infrastructure coordinator
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #299 is a reply to message #285] Fri, 13 April 2012 16:39 Go to previous messageGo to next message
Susanne Wunsch is currently offline  Susanne Wunsch
Messages: 180
Registered: March 2008
Senior Member
Dirk Bräuer <dirkbraeuer(at)irfpde> writes:

> Ich habe beim Erstellen von Beispielen zur Kilometrierung
> (http://www.irfp.de/download/railml_doku_beispiele.pdf, Seiten 4 ff.)
> quasi festgelegt, dass die Ausprägungen 'up' und 'down' der Attribute
> mileageChange.dir und track.mainDir streng numerisch ("hochzählen",
> "runterzählen") zu interpretieren sind und damit vom britischen
> Sprachgebrauch abweichen, wo 'up' = "in Richtung London" und 'down' =
> "weg von London" bedeuten.

Zur nächsten größeren Version soll diese Aufzählung in "raising" und
"falling" umbenannt werden. Siehe Trac Ticket #145. [1]

> abweichen vom Attribut mileageChange.dir, wo sich 'dir' natürlich auf
> die absolute Kilometrierungsrichtung bezieht. (Da es dort das
> Attribut 'absPos' gibt, wäre es konsequenter, wenn es auch 'absDir'
> hieße.)

Zur nächsten größeren Version soll dieses Attribut in "absDir" umbenannt
werden. Siehe Trac Ticket #144. [2]

> ---
> In my examples on mileage I wrote that the values 'up' and 'down' of
> the attributes 'mileageChange.dir' and 'track.mainDir' relate to
> numerical interpretation (raising, falling = "to count up or
> down"). Therefore, they differ from the typical usage in British
> English where 'up' relates on "direction to London" and 'down'
> relates on "direction away from London".

From the next major release on this enumeration values should be renamed
to "raising" and "falling". See also Trac ticket #145 [1]

> therefore differ from the usage of the attribute mileageChange.dir,
> where 'dir' of course refers to the _absolute_ mileage direction.

From the next major release on this attribute should be renamed to
"absDir". See also Trac ticket #144 [2]

Dirk, thanks for your suggestions.

Kind regards...
Susanne

[1] http://trac.assembla.com/railML/ticket/145
[2] http://trac.assembla.com/railML/ticket/144

--
Susanne Wunsch
Schema Coordinator: railML.common
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #300 is a reply to message #299] Mon, 16 April 2012 16:38 Go to previous messageGo to next message
Dirk Bräuer is currently offline  Dirk Bräuer
Messages: 187
Registered: August 2008
Senior Member
Dear Susanne and all "along-readers",

this 'post' is mainly to bring the discussion to an intermediate
agreement. (It is always confusing to have 'open' tasks for years without
knowing the opinion of the others.)

I appreciate the clearness for the next major release.

Just to keep up appearances: @Christian, I think it is still up to you as
the infrastructure scheme coordinator either to agree to the unexpected
usage of mileages or to clarify how it should be done instead.

Dirk.
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #307 is a reply to message #299] Tue, 22 May 2012 21:56 Go to previous messageGo to next message
Dirk Bräuer is currently offline  Dirk Bräuer
Messages: 187
Registered: August 2008
Senior Member
Dear Christian,

since we have agreed in the meantime that the assumptions and examples on
mileageChanges are generally right, there are some small changes still to
do for RailML 2.2:

<mileageChange>.type should become optional (not applicable in all cases,
not at the beginning of a track)
<mileageChange>.absPosIn should become optional (not applicable at the
beginning of a track, redundant in all other cases)

Please close this issue by providing track ticket for these changes for
RailML 2.2.

Thank you!
Best regards,
Dirk.
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #361 is a reply to message #299] Sun, 16 September 2012 20:30 Go to previous messageGo to next message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Dear railML users,

>> In my examples on mileage I wrote that the values 'up' and 'down' of
>> the attributes 'mileageChange.dir' and 'track.mainDir' relate to
>> numerical interpretation (raising, falling = "to count up or
>> down"). Therefore, they differ from the typical usage in British
>> English where 'up' relates on "direction to London" and 'down'
>> relates on "direction away from London".
>
> From the next major release on this enumeration values should be renamed
> to "raising" and "falling". See also Trac ticket #145 [1]
>
>> therefore differ from the usage of the attribute mileageChange.dir,
>> where 'dir' of course refers to the _absolute_ mileage direction.
>
> From the next major release on this attribute should be renamed to
> "absDir". See also Trac ticket #144 [2]

after discussion with the other schema coordinators, we decided not to
wait until the next major release and started with the implementation
within railML 2.2 (see [3]):

The <mileageChange> element gets a new optional attribute "absDir",
which provides the values 'raising' and 'falling'. It will replace the
current attribute "dir" with the next major release and will become
required then.

[1] https://trac.assembla.com/railML/ticket/145
[2] https://trac.assembla.com/railML/ticket/144
[3] https://trac.assembla.com/railML/ticket/159

Regards

--
Christian Rahmig
railML.infrastructure coordinator
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #362 is a reply to message #307] Sun, 16 September 2012 20:48 Go to previous messageGo to next message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Hello Dirk,

> <mileageChange>.type should become optional (not applicable in all
> cases, not at the beginning of a track)
> <mileageChange>.absPosIn should become optional (not applicable at the
> beginning of a track, redundant in all other cases)
>
> Please close this issue by providing track ticket for these changes for
> RailML 2.2.

the attributes "type" ('missing', 'overlapping') and "absPosIn" will
become optional with the next major release since this change is not
compatible with railML 2.x.

Regards

--
Christian Rahmig
railML.infrastructure coordinator
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #365 is a reply to message #361] Sat, 22 September 2012 08:29 Go to previous messageGo to next message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Dear railML users,

> after discussion with the other schema coordinators, we decided not to
> wait until the next major release and started with the implementation
> within railML 2.2 (see [3]):
>
> The <mileageChange> element gets a new optional attribute "absDir",
> which provides the values 'raising' and 'falling'. It will replace the
> current attribute "dir" with the next major release and will become
> required then.
>
> [3] https://trac.assembla.com/railML/ticket/159

In addition to the changes for the element <mileageChange>, it is now
possible to define an absolute (mileage) direction at the beginning of a
track, too. The type tTrackNode has been extended by the new attribute
"absDir" providing the values 'raising' and 'falling'.

Regards

--
Christian Rahmig
railML.infrastructure coordinator
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #371 is a reply to message #365] Mon, 01 October 2012 15:45 Go to previous messageGo to next message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Dear railML users,

>> The <mileageChange> element gets a new optional attribute "absDir",
>> which provides the values 'raising' and 'falling'. It will replace the
>> current attribute "dir" with the next major release and will become
>> required then.
>>
>> [3] https://trac.assembla.com/railML/ticket/159
>
> In addition to the changes for the element <mileageChange>, it is now
> possible to define an absolute (mileage) direction at the beginning of a
> track, too. The type tTrackNode has been extended by the new attribute
> "absDir" providing the values 'raising' and 'falling'.

The mileage ticket has been modified again:
In order to keep a proper syntax, the new optional attribute "absPosIn"
is introduced in the trackEnd element for defining the mileage of the
(incoming) line. Thus, the track node provides the same parameters
required for the mileage description like the mileageChange element.

Regards

--
Christian Rahmig
railML.infrastructure coordinator
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #373 is a reply to message #371] Tue, 02 October 2012 18:44 Go to previous messageGo to next message
Dirk Bräuer is currently offline  Dirk Bräuer
Messages: 187
Registered: August 2008
Senior Member
Dear Christian,

> the attributes "type" ('missing', 'overlapping') and "absPosIn" will
> become optional with the next major release since this change is not
> compatible with railML 2.x.

Accepted - with a deep regret.

> In addition to the changes for the element <mileageChange>, it is now
> possible to define an absolute (mileage) direction at the beginning of a
> track, too. The type tTrackNode has been extended by the new attribute
> "absDir" providing the values 'raising' and 'falling'.

At least for 3.0, I would prefer a solution which describes the mileages
in _one_ structure for easier parsing. (With the above mentioned changes,
the mileages currently are described in the structures <trackBegin>,
<trackEnd>, and <mileageChanges>.)

> In order to keep a proper syntax, the new optional attribute "absPosIn"
> is introduced in the trackEnd element for defining the mileage of the
> (incoming) line. Thus, the track node provides the same parameters
> required for the mileage description like the mileageChange element.

Thank you.

> The <mileageChange> element gets a new optional attribute "absDir",
> which provides the values 'raising' and 'falling'. It will replace the
> current attribute "dir" with the next major release and will become
> required then.

Introducing "absDir": Very good, thank you.

Short remark (only for keeping it in mind for 3.0): Making it required
from 3.0 should not be necessary. 'AbsDir' can be calculated by comparing
two neighboring 'absPos' (better: 'absPosOut' from the previous and
'absPosIn' from the next change). From the triplet 'absPosOut', 'absPosIn'
and 'absDir' of one section, one is redundant. Since we want to allow
'stretching' of absolute mileage, 'absDir' is redundant - we cannot omit
'absPosOut' and 'absPosIn' to calculate whether and how much the mileage
is stretched.

Than you again,
with best regards,
Dirk.
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #379 is a reply to message #373] Wed, 03 October 2012 10:03 Go to previous messageGo to next message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Hello Dirk,

>> In addition to the changes for the element <mileageChange>, it is now
>> possible to define an absolute (mileage) direction at the beginning of a
>> track, too. The type tTrackNode has been extended by the new attribute
>> "absDir" providing the values 'raising' and 'falling'.
>
> At least for 3.0, I would prefer a solution which describes the mileages
> in _one_ structure for easier parsing. (With the above mentioned
> changes, the mileages currently are described in the structures
> <trackBegin>, <trackEnd>, and <mileageChanges>.)

thank you for your good remark. I created a new trac ticket [1] in order
not to forget about this aspect as well as the absDir attribute in
railML 3.0.

[1] https://trac.assembla.com/railML/ticket/166

Regards

--
Christian Rahmig
railML.infrastructure coordinator
Re: meaning of 'up' and 'down' in mileageChange.dir and track.mainDir [message #558 is a reply to message #362] Mon, 26 May 2014 14:03 Go to previous message
Christian Rahmig is currently offline  Christian Rahmig
Messages: 151
Registered: January 2011
Senior Member
Hello everyone,

Am 16.09.2012 20:48, schrieb Christian Rahmig:
> Hello Dirk,
>
>> <mileageChange>.type should become optional (not applicable in all
>> cases, not at the beginning of a track)
>> <mileageChange>.absPosIn should become optional (not applicable at the
>> beginning of a track, redundant in all other cases)
>>
>> Please close this issue by providing track ticket for these changes for
>> RailML 2.2.
>
> the attributes "type" ('missing', 'overlapping') and "absPosIn" will
> become optional with the next major release since this change is not
> compatible with railML 2.x.

In the next major release, the whole topic of mileage reference
positioning will be solved following the new concept. Until then, please
follow the guidelines mentioned in the wiki (see [1]).

[1] http://wiki.railml.org/index.php?title=IS:mileage

Best regards

--
Christian Rahmig
railML.infrastructure coordinator
Previous Topic: Feedback UIC RailTopoModel
Next Topic: How to mark the end of a speed restriction?
Goto Forum:
  


Current Time: Mon May 01 08:13:11 CEST 2017